More flaws and issues with redemptions SIGH

Just tried to do an echeck payment for a family member account >$100

     --Sorry must be between $5 and $100

So I tried to do it in two parts

     --Sorry you have already paid your bill and/or exceeded your monthly limit

So much for redeeming what we want with no limits. At least they fixed the insufficient credit error. One word cellnuvo - testing

It looked to me like the "no limits" might only apply to the 4-month duration. The other durations (including instant) appear to be metered, so it doesn't surprise me that there might be a per-account limit. (It isn't stated, though.)

Swaps and cashing out are two separate things. It makes no sense to allow us to fill up our virtual $ coffers with unlimited swaps if we can't cash them out all at once when we have done the time and funds are available.

I am hoping this is a glitch and no one tested out redemptions properly. Surely there isn't a $100 cash out limit otherwise people doing 9 month swaps for say $500 will have to spend another 5 months to get $100 a month!

Were you able to take 100 bucks?

Okay, that would be ridiculous (having to wait 4 months to then trickle out eChecks).

That is not what we were sold. If they come up with that, I am certain there will then be a mad outcry and drop in users as that would be more unethical behavior (e.g. lies, deception, etc). I for sure would drop usage to s minimum and not refer anyone new to CellNuvo.

I appreciate the 10%, but that is not to justify more of the same. That's to close the book on we messed up on communication and expectations and promise doing good / better fro. Here on.

Mmface wrote, "One word cellnuvo - testing"

Yeah, testing our patience.
Or testing how far we can be suckered. :frowning:

Now I know why they used to say with ring plus that it's a social experiment

Ya know I actually still miss Ring+, and not just because of the free/inexpensive phone plans with their goofy names. I could go for a free Watermelon Plan with 500min, 500 texts, and 500 Mb data. Or a Whole Watermelon Plan with 1000 min, 1000 texts, and 1 Gb data for $5.75 a month..... :stuck_out_tongue: :stuck_out_tongue: :unsure: :unsure: :stuck_out_tongue: :stuck_out_tongue:

We the black don't think Watermelon Plan is a great plan.

Yeah, that sounds a little seedy to me, too (depending on the variety of watermelon, of course). Then again, if they called it the Brussels Sprouts Plan, nobody would ever sign up! :slight_smile:

Well, there may be a glimmer of hope on the Electronic Check front. I contacted Support to let them know that I got that ubiquitous "error" message when I tried to use my available $$$ for an E-Check, and subsequently got a different one when I tried again (PENDING PURCHASE -- TRANSACTION CANCELLED). Got a very nice reply back and they let me know that they did indeed see a $30 E-Check request, that it looked like it was processing, and they'd "advise if any additional action is needed." So maybe those of us who tried the E-Check option may be getting our $$$ after all. Guess we'll have to wait and see, but here's hoping it's a "go"!

If you ever tried my pan roasted Brussels sprouts they'd be the only vegetable you'd ever want to eat. We have them at least three times per week.

No offense intended, @Chelle, but I very much doubt it, as evidenced by this photo of my (very) last encounter with that particular alleged food item:

But hey, look on the bright side -- there will be more for you to enjoy! :slight_smile:

What is that ? A food?

One more reason to love Chelle this wonderful woman who can cook my favorite vegetable.

Don't get your hopes up. For one of my family member's redemptions she was told the same but then today was told it hadn't worked properly so needed to submit again. Then of course back to square one with the same error. Not much use in swapping instantly if they can't get it to work.

I had the same issue but they released another update. With the new update, it worked. It was confirmed with support as well. On a related note, some phones did not update to the newest versions, while others did which also caused confusion.

Using 3.64 too

Same here. I hoped the bug might be fixed with the latest version (3.64), but I got the same error message again. I let Support know, again, and I'm just waiting to see what happens this time around.

Oh I see. Well that sucks!