Activation Issues

Please contact CellNUVO Support directly at Third parties may not be aware of specific services/issues/platforms and may not give out correct information.

I did find MSN in my RingPlus welcome email!!!!! I've just emailed CN about MDN and MSID. Thank you so much for your help!! You are awesome!!

Now CN wants me to manually input my MDN & MSID #'s which I don't have. I already repeatedly told them my temporary phone # is 000-000-xxxx and the device is activation ready at Ting and Tello, but they still send me this procedure to do. I just replied asking them to send me the MDN & MSID #'s. I hope they realize if I already have the MDN & MSID then we wouldn't even be having this conversation.

Below is what I got from asking them MDN and MSID.

You can check under System Settings/About Phone/Status (that should be
basics for most android devices)

CellNUVO Support

If you already have been assigned a 331 area code # then your phone number is the MDN. However for those of us who have not received a 331 area code #, and the only # we have is the 000-000-xxxx then their response doesn't make any sense.

MDN is your phone number

MSID is same as MIN, which I found under "Status" in the setting.

That said, when I followed the direction they had given me, those numbers had been already updated on my phone and it didn't help...

Guff, please check again to see if your phone is currently activation ready at both Ting and Tello.

Tello says my phone is currently active with another provider.

Ting also says my phone is currently active.

Ok, your issue is different than mine. My device is currently available to be activated with another provider and I have not been given a new 331 area code number.

Let's see how CN resolves our issues.

"Tello says my phone is currently active with another provider.

Ting also says my phone is currently active."

It sounds as if your problem is like the one that happened from time to time on RingPlus when an account looked fine on the DashBoard but there was no way for the member to get the phone to provision properly.

Those problems were solved by an "account refresh" which Support had to do on the backend and that may be what is needed in your case.

The fact that your phone is shown as active on the Ting and Tello BYOD checkers makes this scenario more likely.

Thank you. May I pass this info to CN?


If you check out Social you might be able with the Search function to find some specific examples of such cases using the term "account refresh."

OK. Thank you for the tip.

Regarding MDN and MSID:
MDN is what we think of as your phone's "phone number".
MSID is the internal routng # that looks like a phone number.
CellNuvo's recommendation to get these from your phone's Settings menu for manual provisioning is not going to work. If it was in the phone's Settings menu, the phone already would have gone through hands-free provisioning, and you wouldn't need to do manual programming. The ONLY place to get those numbers for manual provisioning is from the carrier/provider.

That said, looking in the Settings menu for this info is useful troubleshooting info. If your phone shows a 330 (or whatever it is) or new 'foreign' area code, and an MSID other than 0's, it has gone through hands-free provisioning, the line is assigned to Red Pocket, and the issue is something else. (Account authorization establishing calling credits, or needing an account refresh, etc.)

I assume, by this, you're only addressing situations similar to @guff's, right?

I mean, in a situation where the device is ready to activate at Ting (that is, one that is unlike @guff's) & has phone number with format 000-000-????, the problem remains that Red Pocket doesn't even have the line assigned to it, right?

Yes, you're correct, jamielih! In your situation, the most likely explanation is that the line never made it to Red Pocket.
I can't think of any other reasonable issue that results in the symptoms of "ready to activate immediately elsewhere", and 000-000-xxxx MDN (phone number).

You are so right about that. My phone already had those numbers after so many updating prl/profile attempts. I've sent them an email about possibility of needing an account refresh, but haven't heard back yet.

Thank you for your help!

CN can....They think manually inputting 000-000-xxxx MDN & 000000xxxx MSID will resolve the issue.

For Guff's sake I sure hope they know what "Refresh" an account means.

I have not tried to activate nor update prl etc.
Are there any disadvantages to waiting for the dust to settle before I try to activate?

Under normal circumstances the only disadvantage I can think of the inability to use the phone.

Here it might be different.

If CellNUVO is in the process of porting numbers to RedPocket and you have not provisioned the device before that completes, then it is likely you will have a problem.