Tello PayGo - does it still need talk/text activity every 90 days?

So I'm a little confused at the end of all the discussion about Tello PayGo needing a $20 top-up every 90 days. :frowning:

Do we still need to make a call/send a text/use data every 90 days?

Thanks for any light folks here can shed on this.

Terms only state "order" now. No need to call/text/use data.

Thanks, mmface.
Sure hope Tello won't change those terms on us suddenly, out of the blue, like they did with the "order" fiasco!

As a practical matter, is Tello enforcing this and cancelling lines that don't meet the requirement?

If you're referring to the purchase every 90 days, no one knows, since the first deadline for enforcement would be in December.

If you're asking about usage within each 90 day period, it's a bit of a mystery, but will become irrelevant if they enforce the purchase requirement. (A purchase counts as usage.) Some have had Tello send a text to their phones to avoid violating the 90-day usage rule-- but Tello has said they're not doing this anymore.

Anyone impacted yet?

Too soon to tell. Earliest date for PAYG lines to potentially expire is December 8, 2019.

Since last payment into acct, so some may be impacted soon, or is the soonest still Dec 8th?

From Georgiana_Tello,

"- When will the 90 days begin? We start counting from your last order with us, or 10 Sept, whichever was last

  • Will you start checking 90 days after the policy was enacted ie 8th Dec? We will not expire any numbers until 8 December"

I burned through the credit on two of my parked lines. The last one has a phone number that I care about so I'm going to put it on the cheapest plan.

Hi Chelle, do you have any advice on how to get a Netgear Fuse activated on Tello?
I have it on my account and did a factory reset (had it on RingPlus and TextNow before) which prompted Hands Free activation ...which fails... then nothing.... :frowning:

I have the msl so I tried to manually set apn etc. but the web page interface is not behaving normally -meaning saving manual entries doesn't work.
I know you have had a Freedompop fuse previously. Any ideas?

I don't have an answer, but I'll be watching this. I had a Fuse on FreedomPop, and I've thought about having it ready to use on Tello as a "what if" solution.

As a data point: I moved my Fuse to Ting for a couple of months after the FreedomPop/Ting transition, and it worked with no additional effort on Ting. (Hands-free provisioning worked.) During my stay at Ting, I wanted to switch from the Fuse to a phone-- which the system did not allow without assistance from Ting. Ting explained that the number assigned (the old FreedomPop number) was a 'data only' line, so a phone couldn't be swapped in to that number. Ting gave me a new number, which allowed the phone to swap in. But that now makes me wonder if there might be a difference somewhere in the Sprint system between a data line, and a phone line, and if that might be applicable to your situation.

Thanks for your thoughtful input and I just realized that I should have explicitly included everyone else in my shout out to Chelle in asking for help. :wink:

johnsmith, absolutely no problem! Chelle's posted about her Fuse before, and her queenly nerd status & the fact that she's tried lots of phone services makes her an excellent choice for paging.
(Of course, Nth Forum doesn't support paging notifications directly, but I'm sure Chelle will spot this.)

Hey there, John! Sorry for the slow response. We're on the road, right now, and I haven't been checking in quite as frequently.

I'm 2,000 miles away from my Netgear Fuse, right now, so I'm having to work from memory instead of being able to get hands-on.

I think that you might be trying to Edit the existing APN, which I don't think will work. What you need to do is to create a NEW APN, save it, and then select that one when you're done. If you try to modify the existing preconfigured APN I think it will automatically revert back when you try to save it.

Let me know if that works!

Hi Chelle, no luck so far but I just discovered something quirky that I have to investigate later when I have more time. The quirkiness is that I have been trying to admin the Fuse from a Macbook using chrome with the bad results and minimal feedback from the Fuse... on a whim I tried to admin from an iPhone and saw an entire series of status screens that were NOT visible from the Mac that described each step of the Hands Free activation (attempt) that still eventually failed.
re your advice- There was no visible existing APN, nor an "ADD" button, only a blank field that seems editable but errors out on submission. Thanks.

@johnsmith I don't have any experience with Netgear Fuse, but here are some thoughts that come to mind.

  1. Have you verified the SIM card installed matches the ICCID used when activating device MEID with Tello? If so, is the SIM card installed properly?

  2. Are you able to factory reset?

  3. Are you able to install most recent Netgear/Sprint firmware?

If the device is failing HFA, I don't see how cellular data can be provisioned properly. I'm not sure the APN settings are relevant until the device completes HFA successfully.

Unfortunately, I agree. :frowning:

johnsmith, have you tried reaching out to Tello customer service?
It's hard to tell whether it's a compatibility issue, a line provisioning issue, or ? I've found email support to be pretty good with sticky issues.

Did you swap the Fuse into an existing line, or start a new line?

I swapped it into an existing line.
I might give cs a shot.