tello google login

Day 3 that i cannot access my Tello account through the blue google login button. i dont have the app.

i get this message

told myself i will wait until tonight before contacting support.

anyone else have this issue?

What happens if you try to reset your Tello account password using your Google account e-mail address?

I don't use Google login at Tello, but don't have any issue logging in with my account email and password.
st3fx's suggestion might work.

It could still be vestiges of the internet problems from the past few days.

It was the internet's birthday and, apparently, it had a wicked hangover.

Gmail was down world wide, apparently. Did not affect me, I was able able to log onto Telling. Maybe your Google acct is one of those affected?

the google email i use is my tello login password. if i change that id need to change the email password. at the login screen under the regular login box there is a blue login with google login button. i press that it verifies my account through google login and it brings me to the account. (is that called hyperlinked idk) anyway id get you a s/s but now tello wont come up at all on chrome. it says took too long to respond. on firefox it states the connection timed out ... and IE ( a browser i havent used in over 8 years) says the page cannot be displayed... all meaning the same thing. tello isnt loading. someone needs to get the internet a bloody mary or something.

I just tried logging in with my Google account and cannot: "Forbidden" The problem could be on Tello's end. I'll see if I can send them an email stating the problem. I was able to log in last night without a problem, and my gmail account has been working fine.

Well, now I can't get to load on Chrome or Firefox browsers. Must be fixing it, I hope.

Thank you! i should have taken down the support email before today but havent and now the whole site isnt loading and i dont have access to the support email.

Maybe someone else on the forum has the contact info, and will lend a hand. But I suspect if the the website is down, Tello is already aware of the problem, provided it's not just down for a few people in a certain area.

Support email for Tello:
Phone support: 866-377-0294 or dial 611 from your Tello phone.

Must be regional, or intermittent. I can still load the Tello site (Firefox 61 on Windows 7 machine), and log in (But I don't use Google login.)

I just received an email response from Tello thanking me for informing them about the problem and asking for addition info, which I provided. So evidently they were not aware of the problem, but are now. It may be that several failed login attempts may cause problems with the webpage access.

Thanks, KentE
I informed Tello that other forum member weren't having problems, and so it might be a regional problem. I just received the following from Tello:

"We have opened an investigation regarding the isue you reported, as soon as there is any update we will notify you."

Tello, like always, is Johnny on the spot when there's a problem.

Don't forget we provide 24/7 live Customer Support, so contact us anytime night or day or check out our Help Center at:
Tello Mobile | Frequently Asked Questions | Help Center.

I am using Chrome.

I am able to login on one of my acct using user name password.
I am unable to login on one of my account using Google login.

Yeah, looks like something broke, either Google changed something or Google Login is still broken.

Thanks, I sent that info to Tello, suggesting that Google login is the culprit.

I just checked my Tello account, logging in the "regular" way using my Chrome browser (the top two lines, e-mail address and password, not with Facebook or Google), and it worked fine. So...

@ferocious-onyx-glossy-iguana-210905, I might suggest that you try logging in that way, using your Gmail e-mail address and your password on file. If you never set that up, as @KentE mentioned above, you might try "Forgot Password" or call Support at 866-377-0294 (or just dial 611 if your phone is already on Tello).

Hope this helps. Good luck and please let us know how things go.

Thanks for that method, but at present neither I nor “ferocious” can get on the Tello website to even attempt to log in, for we get a “forbidden”when trying to connect to the website. Tello said they’re working on it.

Sorry you and others are having trouble with Tello -- fortunately, that is a very rare situation, although that doesn't make it any easier for any of you at the moment. Hope everything gets fixed and is up and running soon!

Just found out I can now load, but when I try to login using Google I still get the "Forbidden"-"You don't have permission to access /account/process_login/google on this server."

Login with Google problem has been fixed according to Tello, and I was able to log into my Tello account with my Google account.
From Tello two hours ago: "We have investigated the problem you reported. The tests made by our Technical Department indicate that the problem has now been resolved."