Payment not going through

Hey, has anyone tried to make a payment with the new version of the app? I seem to be getting an error telling me that I have an insufficient balance. I'm trying to pay for my redpocket monthly but I keep getting that error even though I have enough for it to go through. Just wanted to give a heads up if I'm not the only one.

I asked for a transfer a couple of days ago, while still on v 2.88: it went through fine in less than 48 hours.

It does sound like it might be an issue with the new app. Sounds like an email to Support might be in order.

Yes there have been several reports of the same error message. Old app too doesn't work. CN are aware of the issue so hopefully a fix will be out shortly (edit - by end of Sunday).

Thanks for the info. I'm having the same issue of getting the error message when I actually have enough credits.

Surprised it's not fixed already

I think our developers are top notch but they needed some time to look into this. Should be all set shortly. If anyone has issues they can email our support team for urgent issues and they will work to make sure you’re squared away.

Same issue here, sent email plus 2 screenshots to support.

Anyone tried it today?

Just tried it at 3:55pm eastern time and it is still not working.

I put in a payment to Sprint using v3.00 earlier today and I didn't get any error message.

Might need to refresh the app or something. Force close.

Same here, still can't pay.

Just got this message from CS
CellNUVO commented:

We are working on fixing this issue- I don't have a resolution from tech just yet but will advise as soon as I do. Thanks and have a great night!

Friend of mine was able to do a phone installment payment just now. She was getting that error message before so looks like they fixed that part/her account.

May be affecting a specific batch of accounts... just tried, still no go.

Got a message from nuvo stating that payments have been fixed now. All is good for now.

just tried, mine still not working...

Yesterday I put in a payment to Sprint, and just now I got confirmation from Sprint of the payment. That was the shortest ever turnaround time for me, just over 24 hours.

Still not working for me. Also, did not receive email from support, so maybe they are notifying people as they fix the accounts.

You might want to send an email to support. The only reason I got the email telling me it's working was because I previously sent one to them.