Outgoing calls on Premium Voice not work, anyone else? or have a fix?

Anyone else? Data works, incoming calls work, just outgoing calls on Premium Voice yields a "We are unable to complete your call." message.

FP Help on Twitter has tried de-activating and re-activating Premium Voice but still no success...waiting on further instructions.

Looks like a few others are having the same issue, but unclear if anyone's had it fixed yet...
[li]https://forums.freedompop.com/us/discussion/36008/sprint-premium-voice-cannot-make-outbound-call#latest [/li]

Still not working...waiting on their helpdesk...

I don't have premium voice, but you might consider the version of the FP Messaging App you're using.
If you haven't updated it in some time, try updating to the current version. (Although I'd extract the apk, or confirm that I could source the older version somewhere, first)

If you do update regularly, see if you can find an apk for a slightly earlier version.

Thanks for the tips. I’m on an iPhone so no app at all. With Premium Voice, I just use the native dialer and it’s worked fine for over a year until sometime mid last week.

Still working with help desk and have done the standard toggling airplane mode, ##UPDATE#, ##CLEAR#, and they even had me do a factory reset on the phone...but so far none of their tips have fixed it=(

Perhaps they scaled back support on Freedompop to encourage you to switch over to Unreal...

Closing the loop here, this was finally resolved on 9/12. The Premium Voice outage lasted ~ 2 weeks for a subset of users. FP credited me back a month's Premium Voice fee for the outage. All in all, not too bad since I was able to make calls via LTE/WiFi using Hangouts. Resolution took a while but they were responsive to my frequent check-ins for status.

It didn't look like it the outage was too widespread, but there were a few threads on FP's own forum with several others affected.