Our latest Obi-related saga...continues!

Now solved - but I cannot change the title - sorry !!

This all starts with the apparent EOL for Circlenet, which we used for keeping our faithful Obi110 online with GV.

After looking at the options - and mostly for the sake of simplicity - I settled upon getting a used Ooma Telo from someone at fleabay for a much better price than any new one could be found at.

It arrived & was activated via their phone folks - plugged in correctly - cycled through a bunch of colour changes for its light - and then just shut itself off.
(Wasn't even possible to reach into its own mini-server via browser to do a factory reset - zero response.)

Tried all the various tricks via their 'support' and forum only to have their chat agent tell me outright that the unit was defective & to call tomorrow about it.
Double woof.

Looking once again at the options, I was just -this- close to pulling the trigger on an Obi200 for $40, when the Ooma rep told me that as a courtesy they will mail us a new replacement at no charge !!
Wow (no woofs here).
They even want the dead one in-hand so much that they'll pay for the shipping to them of that - which of course I'd love to see gone as it is merely a brick.
Double WOW.

So now we wait & see how the rest of this unfolds in maybe 5 days or so when that arrives, meantime its not like that line gets much usage anyhow, so a little waiting time won't hurt.

How's that for surprising ??

It's surprising, but I wonder if Ooma has something like certified sellers of used or refurbished Telos and is thus interested in not only what is wrong with the device you purchased but also who sold it to you and where it came from. If many defective Telo devices are sold, Ooma's reputation is harmed--hence the desire to get hold of and investigate your defective device. But kudos for Ooma for taking good care of you.

I'll try to make this NOT put the reader to sleep as it is overly long and goes from the ridiculous to the absurd...

Given that a shiny new wired Ooma costs ~$100, that was a non-option for us, and we got the way cheaper used one via fleabay...and as told before, it didn't work for some unknown reason, not no way, not no how - so they told us they'd send out a new one - pretty good of them, IMO.

In the meantime I asked them if they could confirm that their service was OK with comcast service, and they insisted that it works 100% fine with our ISP & our (cheapest level) internet only service.

The free (new !!) replacement arrived - and it didn't work here either - and all of this ate up serious amounts of time with their phone people - who ultimately sent out yet ANOTHER new box for free - wow.

The 3rd box came & it also refused to work.

Not wishing to spend even more of my life having non-discussions with their folks who clearly had no clue why these things utterly refused to work - I tried LOTS of stuff, and - also located a cheap, but new Ooma wireless USB adapter & ordered it (they are discontinued now, BTW...).

Meantime - I was very, very baffled as to why 1 used & 2 new Ooma boxes would not respond here in ANY way as they were supposed to.

Lucky for me, our neighbor also has comcast & I was able to connect the newest box directly to his modem/router - and guess what ?!?
It cycled up & got to the blue mode, meaning it was all ready to make calls (I had no phone with me).
Came back here & connected it - nope, a total no-go...again.

So I got a bit creative and imposed a switch (like a network hub, but better) between our cable modem & the rest of our home network - hooked up both the Ooma ethernet connections to that as well as a separate PC to try and contact the Ooma's internal server (setup.ooma.com or and it was a total non-response as well...UNTIL=>
Just for yuks, I removed the 'internet' RJ45 - and holy cow - the setup page came right up !!

Went through ALL of its pages & options & gave it a static IP address so as to use the cable modem directly, and after a restart it still responded, but still could not make the needed Ooma stuff work to get their services.
(It did show as having an active account with the correct number too.)

Tried the same procedure with the prior new box as well as the used box - did ALL the same settings changes - and they worked for their internal server contact as well...only.

A day or so later the wireless adapter arrived - and after a prolonged boot-up time, that was able to see both our wifi as well as the next door neighbor's - and amazingly, once the ethernet connection was removed - the latest box went 'blue' via wifi only...Wow !!!

Feeling quite optimistic, I unplugged it, moved it across the room, and powered it up again, and waited and waited and waited - but it stayed 'red' - another no-go.

Pulled it (GROWLING !!) crossed the room and plugged it in there & waited (coffee time...) came back, and...'blue'.
Woof - WTH is going on here ?!?!?!?!?!?

Diagnostic mode engaged - so, what is different from this, to 6 feet away, really ??
Checked everything until finally looking at the wall-wart which had come with the used Ooma - 5V (check), 400ma...huh ??
The Ooma boxes require 5V 3A - which the new one came with, whereas I'd left the original wall wart plugged in as it is in a nasty spot to reach - so I changed that, and what happened ??

Boot up followed by solid 'blue' & working 100% for calls in & out.

Conclusions after all this absurdity:
1 - Minus the correct PSU the Ooma will start & -appear- to run, but isn't getting enough Ooomph to work 100%;
B - The weaker PSU could not power the wireless USB either;
3 - Our cable modem, a Motorola SB6121 isn't allowing...something through that Ooma needs, even though all other devices get along with it just fine.

Since the Ooma folks told us that the other devices are now 'blacklisted' and can never again be used - I pried open the used box - and now I see why these can be given away so freely - it is merely an SBC with very few components, the sort of board that gets outsourced & maybe cost ~$10 each to get in hand & all the rest is a glued together plastic case, the PSU & a cheapo patch cable.

Selling these for ~$100 must be very profitable is my guess, and now that they have the wireless model for even more & a 4G model too, they likely have plenty of these on hand to keep their customers happy.

So we finally have a working Ooma for a cost of under $5/month with 2 numbers (non-premium) 2 useless boxes to toss out, and an extra PSU in case the other one fails.

Based upon al the above - are we happy with this ??
Except for the time wasted upon getting non-answers from folks who know too little about what they support...

At some time in the future I will consider getting an updated Arris cable modem/router with wifi as good models can be had cheaply - but that can wait as it is another spend that we can do very well without right now.
(Have I put anyone to sleep with all that ?!?)

Wall warts are sometimes appropriately named. And whoever said the "process" was more enjoyable than the end result must have been joking or had a scenario quite different from yours in mind. Lesson learned that it's a good idea to check the power supply first when things go awry. In any case, glad you got it working correctly.

I'm a little confused by your conclusions. Unless either you have two different home internet providers for some reason or you currently have your Oomae connected to your neighbor's wifi, doesn't the end result indicate that there's no issue with the cable modem and it was all the power supply the whole time?

I am no less confused actually by the same things...because:
The wireless adapter was a last ditch attempt to get it to connect - just because it was cheap enough to gamble upon - and as I tried to describe, the box's own little server indicated that it 100% had confirmed internet connectivity - but was NOT able to complete the VOIP connection with the Ooma servers.

It also refused the direct PC connection with its internal server with the 'outgoing' RJ45 connected - but connected fine with that page after that single cable was removed.

Giving it the directions to connect with our (separate) wifi router allowed the full VOIP connection to occur, somehow.

As to why that would make it through our cable modem vs. the 100% wired connection that would not - I have no clue and agree that it is not logical - but that IS how it happened, and it was repeatable as long as the stronger PSU was used - as it baffled me & I re-tested it several times.

Using the stronger PSU with the wired-only connection did not work for their VOIP to connect, ever.

Since everything else here - including an Obi box & a SIP phone work fine, I must guess that using our separate wifi router somehow changes something and 'fools' the Ooma box, allowing it to connect...somehow.

Electronic voodoo, perhaps ?!?

The wired connection (apparently) worked in your neighbor's house though, right?

I doubt your SB6121 cable modem is causing the problem. It's more likely a cabling issue, hub/switch issue (I've seen strange things happen with "green" switches and older NICs), or router issue.

If you are interested in discussing/troubleshooting further, I would like to know more about your network setup.

Hi St3fx & thanks.
Yes - the wired connection worked on our neighbor's Arris cable modem that does have wifi & router built into it.

Our SB6121 cable modem is the plainest of the plain - no built-in wifi/router, just a single RJ45 port, power & cable in...that's it.
The only config option it offers via its IP accessible 'server' page is lights on or off - no FW or DMZ at all.

The Ooma failed in ALL other wired scenarios - straight to the modem's RJ45 with not 1 - but FIVE different patch cords, all factory made because its failure was so baffling - in fact, because I make ethernet cabling I even put 'em on the cable tester & got 8/8 on all of 'em - no troubles there.

I do not even own any 'green' switch (and wouldn't) nor were any NICs involved at all during the direct testing phase.

Our house has many wired in devices including the older wifi router it is using flawlessly right now - but when I was totally baffled by the Ooma I disconnected EVERYTHING so as to be sure any other possible causes were eliminated.

I only interposed the switch for when I wanted to poke further at getting the inbuilt 'server' page up WITHOUT having to disconnect all our other devices - so during the weeks in which I left it that way, ALL our household internet connections passed through 2 ports of that switch with zero trouble.
I then used 2 more ports for both of the Ooma's ports, and 1 more for the PC I was using for testing it.

Again - no trouble with ANYTHING else here - PC, TV box, VOIP - but the Ooma ?? Nuttin.

Getting that silly thing to present its config page was the 1st 'win', setting a static IP to be 100% sure it could reach the internet was the 2nd - which it confirmed - pinging it went fine - but connected with internet the config page went away every time.

So - again - the wireless dongle came - entered the config page as described - told it to use our wifi - and after the PSU snafu & some waiting - it has been fine ever since.

The amount of time & efforts of my life that I have spent upon the Ooma alone could pay for maybe 10 of them at retail - and all this for a phone that my partner very seldom uses at all !!!

That's it.

Today's calls to them to make sure they weren't going to break their promises of a free replacement was the last bit of time I'll waste on this silly thing, BUT:
While I had the 'tech' on the phone - aside of demanding a confirmation email - I also repeated myself until he responded in his broken english that he was entering our modem model number for their even higher level tech folks to verify...somehow.

And that, dearest reader - is THAT.

For anyone considering the Ooma option, I suggest to keep in mind=>
It is a locked down & special purpose ATA over which the mothership has 100% control - makes our Obi box look like a wild free-for-all by comparison.

The innards of it are minimal thereby proving their profit margin from the $100 retail pricing is very good.

When it works - it is very nice & can be very good for anyone tech-challenged UNTIL anytime that it won't work at all - then it is anything but simple & their support is just offshored phone answerers with zero tech savvy.

We did not pay anyplace near the $100 to have one - and would not have paid that much, no matter what.

The Obi2xx is a far better option for anyone NOT as technophobic as my parner & well worth its $40 cost when on sale.

2nd to that, ANY ATA (even an outdated Obi1xx !!) with a really good company like voip.ms will fill such a need very well.

And now our story is all told !!
Thanks for reading here.

Thanks for taking the time to provide details, Et_Z. Now that you finally have it up and running, I'd be grateful if you could report after living with it for a while on how-it-works-when-now-working. I know more than one technophobic person who might benefit from an Ooma, although none of them would likely be able to get through your scenario to get it working in the first place. (I have to think/hope your troubles are not the normal case.....)

@Extraterrestrial_Zoologist Thanks for all the details. Did you power cycle your cable modem after connecting Ooma directly to SB6121? In my experience, a cable modem "remembers" the connected device MAC address (eg; router) and will not DHCP to any other MAC address unless power cycled and a different device is connected to cable modem at boot up.

Yes, yes and YES !!!
Also, the 6121 was not being used for its DHCP at all as I set a static IP & it did show that IP in its status page.
No idea how many times I power cycled EVERYTHING, but it was...ALOT !!!

Your SB6121 only supports 1 device/MAC address for WAN (and I think it would ignore/discard communication from any other MAC address, even if using static IP). It sounded like you were trying to connect both your Ooma and wifi router simultaneously to cable modem. You should be able to connect to wired (ethernet) LAN on router, since Ooma works over wireless LAN (wifi).

Looks like a very strange re-interpretation of what I've already explained here, which should hopefully make more sense to you this way:

SB6121=>Ooma...PERIOD - even that had zero VOIP;

SB6121=>switch=>Ooma - internet but NO VOIP;

SB6121=>entire home network via wired router (DHCP ACTIVE) including wifi router (NO DHCP)=>Ooma with wifi...
Ooma VOIP = All good.

The above does NOT include the bazillion attempts, resets, etc.

Too bad, E_Z, that for a phone system that touts simplicity of set up, Ooma turned out to be a WTF for you. I used an Ooma maybe 10 years ago when the Telo first came out and even though my slow internet speeds were within the prescribed acceptable speeds Ooma required, I could never obtain acceptable call quality no matter if I connected the Telo before or after the router and no matter how I configured QoS on the Telo. Looking at the below Ooma set up video earlier today, it really is a mystery as to where the glitch in your wired system is. Hey, it works now, though.

I might be misinterpreting again, but it sounds like you have a wired router and a separate wireless "router" configured as an access point/bridge. I'm not sure if you tried connecting Ooma via ethernet to your wired router or wireless "router", assuming either has a built-in ethernet switch.

Aiming vague assertions of incompetence in my direction regarding my long time occupation is NOT any way to get my cooperation - much like the steve nuisance troll at the Obi forum - who learned he was better off NOT contributing his difficulties to anything I posted there.

I'll not try to 'splain this again for your benefit - it was all EXACTLY as I've already said here.

Given the rather large number of networks I've made - worked on & corrected for 20+ years worth of clients, and adding in that even the supposed high level Ooma folks have no explanation of what happened, this part of the saga concludes thusly:
The Ooma Telo is now connected happily via wifi along with ALL the other wired & wifi only devices we have, sitting there with its little solid blue flower lit up happily, and acting like a usable phone device should.


For anyone who is NOT attempting to mis-diagnose this strangeness for me when I didn't ask for any - I'll be happy to post back with the as-we-go-along details later on.
Thus far, after some part of a week in use - it has been fine - and even when the Ooma tech called in on it, it worked as it should - much to his bafflement.

Ok. I'm not sure why you thought connecting a switch to your cable modem was a good idea though.

I appreciate the story, at any rate. I'm a programmer, not a network tech, and I think it's been over a decade since I attempted to connect anything directly to the modem without at least one router in between (and sometimes also...something else); so some of what you have described was particularly fascinating.

At one point I thought you were saying you had the Ooma configured to request a static public IP and connected to the modem directly with no router involved, which as of the last time (circa 2005?) I had any occasion to wonder about, I thought most ISPs charged extra for. On rereading, though, I think I misunderstood that part; and at any rate, it still wouldn't explain wifi working but wired router not.

As for the convenience, for several years now my sister has been on Ooma and I've been using Obi+GV (although I only recently started having the Obi register with GV directly instead of GV->DID->pbxes.com->Obi) and yes, as I understand it, she has had to fiddle with hers far less. I don't think anyone even ever shipped her the wrong power adapter. I hope from here on out your experience is as smooth as hers.

Thanks Scriptninja !!
The silly Ooma is still working fine - and here is a bit of a clarification, perhaps:
Our cable modem has its own DHCP server with a limited range, and also allows static IPs to be assigned above that local range for devices on the LAN.

In my vast time wastage with the Ooma collection, and literally nothing working as advertised - I experimented to see if I could get ANYTHING to actually work at all.
Since the cable modem has just a single RJ45 output socket, and it turned out that I needed 3 ethernet connections for the doggone Ooma to respond AT ALL - I stuck the switch in after it to make those 3 available - and by golly it did work - just not for the Ooma VOIP.
It was repeatable as well, with the other 2 (blacklisted) devices responding the same, exact way.

I remain quite certain that somehow using the downstream wifi router to 'isolate' the Ooma from the upstream cable modem did the trick - but of course there is no way to be 100% certain & frankly if I never have to waste time & efforts fiddling around to satisfy a glorified ATA again, that'd be fine with me !!

And...as I told the Ooma rep:
If it goes bad at some time in the future, I'll take the nasty thing outside & run it over with the car to be SURE it will be dead & gone for good - too much is enough already.

ATA boy--E_Z.:whistle: