LG X-Charge listed as incompatible

My unlocked LG X-Charge purchased from Amazon (Unlocked LG X charge from Amazon Prime (US601) | LG USA) years ago was used on R+ (I think), Ting, FreedomPop, and at one point, Tello.

Today, Tello's IMEI checker site says: "Oops! Your phone is not compatible with our GSM network. Please note that you need a compatible device in order to use our service."


As a device originally released in 2017, it might not be T-Mobile VoLTE compatible. Can you check the IMEI at the following site and report the results?

T-Mobile IMEI Check
Click Question Mark After Entering IEMI For Detailed Info

Thank you for the mint mobile checker. The checker reports incompatible.

So looks like VoLTE is the standard. I'll see if I can find a data-only plan & SIM to continue using this phone. Or, it's time to replace it.


To avoid buying another phone for Tello, I found that both the Tello and Mint checkers indicate the ZTE Blade A3 Prime (from Visible) is compatible.

What's a good way to determine if it's unlocked?

The checker is wrong. For the most part, the ZTE A3 will only work as a data-only device on T-Mobile. It cannot do VoLTE on T-Mobile. Also, Visible locked out 2G and 3G GSM voice/text capability on the A3. For all intents and purpose, the A3 only has full phone capability on Visible and Verizon.

Checked Hello Mobile's checker, which said that both the unlocked LG X-Charge and the Visible ZTE Blade A3 Prime are compatible. I'll assume the ZTE A3 result from Hello Mobile is wrong, but how about the result on the LG X-Charge?

Sorry for beating this dead horse.

Good news and bad news.

Just for fun, I temporarily moved an existing Tello SIM from a Moto G6 into the LG X-Charge, and everything works! Data, calls, texts. The phone call screen (dial pad?) had a "HD" by the green call button at the bottom.

Then, I ordered a new Tello SIM, intending to put it into the X-Charge. When I received the SIM, I tested it in the X-Charge, and it worked just fine, same as the SIM I tried previously. Because the X-Charge was going to a different person, I then did a factory-reset. Upon factory-reset, the "HD" by the green call button was gone, and nothing works. I messed with all the APN settings to avail, comparing with other working Android Tello phones. Using the SIM I tried previously did not work either. Making the phone do system updates didn't work either, as I imagine LG has long turned off that service, and especially since they're no longer in the phone business.

If anyone has any ideas, please let me know. I'm gonna see if i have an old Sprint SIM and seeing that will allow system updates.

No HD sounds like VOLTE is not enabled when you reset the device. Did you check to make sure VOLTE is enabled?