I can no longer make/receive phone calls via FP app


Muy phone is a ZTE maven 3 locked to att prepaid. But it used to work with fp app.


Was there any updates recently?

Yes, I updated it to the latest version and it worked for a few weeks.
Now whenever I want to make a phone call it just shows me a spinning circle.

I hope some do users can help you.

Until then basic trial and error

I am not familiar with fp. I hope others chime in here

Update:. I edit my post since Chelle who has fp suggested the opposite


I think in the FP Messaging app menu, there is a selection for 'refresh' or similar.

Since you're seeing the spinning circle, I assume you've tried directly opening the FP Messaging app, rather than just waiting for the notification bar to finish "registering for push notifications". (One of my phones will frequently get stuck on 'registering for...' , but will complete registering if I open the app manually.)

That said..... On one phone, I did successfully use the app for both calls and texts a couple of days ago. On my other phone, last night, I could not get the app to register despite trying my suggestions above. That phone, however, is probably running an older version of the app, on Android 4.x. (I don't regularly use the app on that phone, and don't update it until something is broken...... I didn't have access to WiFi to try updating the app.)

Clear data on the app and you should be fine. It will resynch everything and should start working correctly.

Thank you beautiful. Your solution makes sense so I tried it immediately. Unfortunately it did not work for me. This happened to me before and I found that an older version of fp app would solve the problem. Last time I accidently update it to the latest version and it still worked so I did not bother to revert it to the old version.

Your welcome,. Thanks for the compliment. :slight_smile:

LOL, I didn't know that you are a girl or beautiful one, but thanks anyway.

Just playing. I know you were talking to Chelle as normal. needed a laugh.

Did it work?

Can't remember which version, but I know I found it in howardforum. I have to dig again.

You are absolutely correct about using an older version, Hawg. I'd almost forgotten about that.

I have two identical LG Phoenix 2 phones on FreedomPop and one of them has to use an older version in order to be able to make calls. The other works fine with the latest version.

I bought the phones within a week of each other and they're identical in every way that I can think of.

Actually-- now that I'm thinking about it, one might be locked to AT&T and the other is unlocked. I'll have to play around with them and see if the locked phone is the one being fussy about app versions.

Hi beautiful, my zte maven 3 is locked to att. Could you please tell me which old version are you using?


This one works for me (ver. 19.02.789.0405). Don't forget to disable autoupdate for this app in Google Play settings.

Current non-working version is 20.01.864.0629
Last edited by RFK; 07-08-2017 at 10:34 AM.

Glad you fixed it

Same, here. I need to stay under version 20!

I haven't done it yet. Will provide update later.

That is a post from Howard forum.

I replaced the current app with the 19.....4045 version from Aptoide only to find that my phone cannot be registered for push notifications.

So I uninstalled it and downloaded the version from Google play store. Surprisingly, it works.