Freedompop LTE SIM $1 at Target, ends today 1/6

In case anyone's needing a SIM:
Target has the LTE SIM for $0.99. Shipping is additional, but shipt-to-store is free. (Or maybe your local store has it in stock.)
The sale ends at midnight 1/6.
[EDIT: the sale is still live as of 1/10, and is also available at Best Buy now. Sorry, I can't seem to edit the Subject line.]

I know these are currently available directly from FP for $0.01-- I can't confirm it still works this way, but the last time I ordered one from a 3rd party vendor, the SIM could be activated with the basic/free plan, instead of having to downgrade from the trial offers.
I see that one user comment on the Target site said it cost $0.99 to activate the SIM......

Are these sims gsm or cdma
If gsm will they work with a 2g 3g tablet?
BTW they are still on sale @ the target website as of 1/07

They're GSM/ AT&T.
Don't worry about them being marketed as "LTE" SIMs-- they are, but they also get AT&T 3G. (It should work fine in your new tablet in the other thread, even though it doesn't have LTE radio.)

AT&T 3G coverage is very good-- they use 3G for voice, so it's their broadest coverage band. (But you won't get cellular voice with the FreedomPop SIM, only data and voice-over-data.)

Thanks for noticing that the sale is still on, als!

And, starting today, also at Best Buy:

Shipping is additional at both sites-- but at least Target has free ship-to-store if it's not currently in stock at your local Target. (I didn't check to see if Best Buy will do that.)

Can anyone confirm that you don't have to downgrade these?

I'm leery about freedompop. I got burned with extra fees and charges back in 2014.
Their website offers a 1 cent sim with 2 gb free for first month,But the fine print says the triall starts when the sim is shipped. which will do me no good now.

What hoops do I have to jump through with the target freedompop sim?
I just ordered 2 from target
I'm thinking i've got over 1 gb on mytracfone thru verizon
I can add one month tello 200 mg to my paygo with unlimited fallback to 64 gb
that will give me some coverage on three of the carriers
Seems the days when I could just stop @ the nearest phone booth and check the local listings was:( easier

Best Buy has free ship to store also.

Just to make sure-- Tello is on a different device, right? (It won't work on your new tablet, since Tello is Sprint/CDMA).

I haven't activated a FreedomPop SIM from Target, but the last one I did from a different 3rd party vendor did not require starting with (and then cancelling) the free trials. It could be activated straight with the free plan-- although they offered the options of free trials of the paid add-ons when I activated it.
Buying straight from FreedomPop, the SIMs are activated when they ship. Buying from a 3rd party vendor, the SIM is not activated until you go to the freedompop website to activate it. You can stick it in a drawer and wait, if you wish.

Looks like I'll be carrying a tracfone. with about 1gb data
tello phone paygo + 200mg with 64lk fallback and
tablet with a freedompop gsm, looks like I only have one sim slot on the tablet
Is it possible to switch between freedompop sims on one device

Sure, it's fine to swap between GSM SIMs on a single device. You can carry 2 FP SIMs, and swap back and forth as needed, or swap to a SIM from almost any AT&T or T-Mo MVNO as needed. (Except for a few, including MetroPCS, I think).
In most of GSM world, your phone line is in the SIM card, not in the device itself.

If you switch FreedomPop SIMs, you may have an issue using the FreedomPop Messaging app without re-installing it to match the SIM card. Although a lot of folks never use the FP Messaging app anyway, and choose to use Google Hangouts for VoIP calls.

Good question. Can anyone answer this?

I picked up one today. Maybe Monday or Tues eve I can activate it & report.

Any luck activating? Do you have to down grade? What is the credit card liability you have to post with freedompop to gain access
I'm super leery about giving my credit card info to freedompop due to a lousy experience back in 2014.

Sorry, als-- been busy with work, and haven't had a chance to activate the new SIM yet.

I am positive you'll have to add either a credit card, or link to a PayPal account. Some folks used to use an expired card, or a card with very little value. (Like a prepaid card). You should be aware that FP now charges a $0.01 charge at seemingly random intervals-- theoretically if your line is dormant for a while, but it seems to crop up for some users even if they regularly use the card, and I'm tempted to think it's primarily to confirm an active card on the line. If the $0.01 charge doesn't go through, they'll suspend the line.
Some credit cards allow you to create a virtual card, with a selected expiration date and dollar limit. This would be a good route, although you'd need to remember to come back and replace it when expiration (or value limit) approaches.

I got my sim off of ebay. It came already downgraded with with automatic top up taken off
And it had the sellers credit card number on there so I didn't have to enter my own credit card number

But, it seems likely an ebay seller wouldn't leave a 'live' credit card number on the account. It's either a dead card, or a time-and-value-limited card. Hopefully the latter, with enough room for multiple $0.01 charges that might happen, and an expiration date far enough in the future.

I make calls every month with it, so I have never been charged $0.01

I tried to activate my SIM from Target today. Can't get it to go through. The activation website keeps failing on the final step, saying only "an unexpected error has occurred". Since I've tried 2 browsers & 3 credit cards, and the site isn't giving me any further info to understand what the problem is, I'm going to wait & try again later.

But..... I can clarify some of the steps.
The directions are on the SIM package-- go to Activate | FreedomPop.
It appears to me that it should be possible to activate requiring only a $0.99 activation cost-- added to the $0.99 + tax cost of the SIM.
[EDIT to add: and without any of those pesky trials that you need to downgrade.]

There are several steps, where you will be presented with the chance to add on trials or larger plans.
On each webpage (heading) below, I selected the following choices:

  1. Free Trial Offers: under Continue button, select tiny print 'No Thank You' (Do not press 'Continue')
  2. Select the Plan that is right for you: Select Basic LTE 200
  3. Congrats, you're qualified.....! : Select tiny print 'I don't want free stuff' to the left of Continue
  4. Final Activation page: uncheck $10 credit applied-- this should reduce the total cost indicated from $10.99 to $0.99

All looks as I expected that far-- but after Continuing, I get whirling pattern followed by Unexpected Error..........

If your activation goes through, remember it will still cost you $5 if you want to disable auto-topup. I watch mine pretty closely, and don't disable top-up if the SIM is in a phone that allows me to set a safe data limit.

Another note: the Paypal option I've seen before did not appear for me today-- so a traditional credit card was required.

KentE: Make sure you're not using VPN that takes your IP location out of the U.S. Also, try a different credit card.

I tried activating the SIM again last night, from home. (Earlier attempt was from work PC.) Still didn't go through. Sometimes the same 'unexpected error' notice, sometimes just failed with no notice. (After each failure, the $10 deposit checkbox rechecks itself, and needs to be deselected again to avoid that charge-- so be careful if you have the same problem with activation failing.)

No VPN either location, and I've tried multiple credit cards. Also tried clearing the cache and history on my browser. .

I checked the FP community forum-- while no mention of this particular problem, there were a number of complaints from people about inability to log in to their accounts over the last couple of days, with password verification not working.

I'm trying to set this SIM up on a new account, which requires a new temporary password generated. Possibly my failures are a result of that more general problem. I'll try to try again later today.