Fp GSMA is a waste case after all (IMO)

Just came to my renewal/expiration time with the 'free' GSMA deal.

1st - no longer any way to renew from their site - it has been removed;
2nd - Open their app & it offers to renew via a button that is ~2/3 obscured at the very bottom of the screen - and it does not accept touches, EXCEPT=>
In trying to touch it, it keeps going back to the top screen or plays endlessly annoying ads.

So, unless I am able to make it renew somehow, it'll be allowed to cancel & I'll just make do with my happily paid US Mobile line alone.

My partner (for now...) still needs her backup phone & unless she takes retirement before that coverage runs out, I'll be glad to pay the $60 to Redpocket rather than enduring the fp absurdities.

Unless this gets easier my view of fp has fallen to a NEW & IMPROVED all-time low.

What type of phone? Can you put the sim in a different phone and try it? I'm not having any trouble renewing any of the lines I manage.

1 Like

Thanks for your thoughtful reply SBlake5.

It is an LG Phoenix3 with a good, big screen (IMO).

I can try it with a Moto E6 - but that screen size is about the same.

Does the SIM actually need to be in the phone to renew??

If the GSMT line I manage came to the same app only situation I was going to install the app on an old ipad to renew since I don't have regular access to the phone actually using the service.

1 Like

You know, after thinking about it, the sim does not have to be in the phone. You can renew from any device with the app and wifi/data source. .

1 Like

Hello Again SBlake5 & Redrotors.
I did the SIM swap exercise - that will happen JUST THIS ONCE !!
(No small feat with those itty-bitty things !!!)

In the Moto E6 the button was fully visible - it took all 10 of my touches & ONLY responded with ads & ads & more ads - and never renewed.

There must be a clause in their TOU that specifies they are allowed to torture free users endlessly - that is my best guess.

As to using another device for their foolish app - we have no i-things at all, will not spend $$$ on those, nor do we have bigger screened Android devices.

I did open a ticket about this via the fp site - but they have not replied.

Bottom line for me:
If it refuses to work online or in the phone & cannot easily be renewed - then it is just a needless hassle & was a waste to get at all 'cuz fp is a waste of time.

Slight addendum, a bit later:
Because of the replies here I thought of my Textnow phone & installed their app onto it.
Opened & logged in OK, came to the screen with the 'renew now' & it also took all 10 of my touches & ONLY responded with ads & ads & more ads - and never renewed.

Too much time & efforts wasted on this torturous stuff.

Well, that sucks.

Thanks for posting all that One.

Curious how long the ads were, I'm assuming you let them run to the end of each?

If they are going to this model forcing you to watch at renewal (when the line is probably dead already) is really inconvenient vs. the model where you earn credit towards service for watching ads when it works for the subscriber. Seems they really just want people to cancel the free lines.

1 Like

Hello One, I hope this might be of some help.

After you watch the ad , two clickable boxes should appear (I can't remember the wording in the boxes). Don't click on the top one, Click on the bottom one, which will take you to a page to imput your renew info. When I renewed my GSMA line on Wednesday I made the mistake at first of repeatedly clicking on the top box and ended up in the "ad loop" for a while.

If the above doesn't work, I saw in another Forum a post from someone who was also having problems renewing on the app. He called CS and spoke to a rep who let him renew over the phone. Even though you are past your renewal date you still sould be able to dial 611 on your FP phone and talk to a rep. If not, you can call (888) 702-8302 from another line.

1 Like

Hello & Thanks SeanW.
Seeing your reply here I tried again.

1st using the Phoenix3.
At those times when the renew button worked, ads came on - were allowed to play through - and there was nothing like what you've described, only opportunities to install apps or buy stuff.

2nd, using the Moto E6.
As before, screens were more visible & it was easier to hit the renew button.
The results were the same except for 1 small detail=>
I had to re-login several times when the app did a FC, with the same results.

Wow, have I ever wasted alot of time on fp - and their so-called 'support' cannot even be bothered to answer my ticket either.

I'll try just ONCE more via calling, and then...I give up !!

611 did work & it knew it was on the right (expired/suspended) line.
After being forced to hear their obnoxious hold music & that I was '1st in line' for 10 minutes, I'd had quite enough torture & gave up...again...so=>


That does seem to be their goal.

I also could not figure out how to renew the GSMT plan using the app when I tried a few days ago. Fortunately, the website renewal worked.

Other than the ads, I had no difficulty renewing my GSMA lines through the app this morning.

For the reference of anyone who comes across this to whom it is useful info, what happens for me seems to be as follows, on a Galaxy S21FE.

One note: The reason I can currently still access all of these steps is because my GSMT line went to Airtime Expired (due to their disabling autorenew) shortly after I last renewed my Nearly Useless Free Plan line (which was never able to auto-renew) in mid-January, I think it was, and by the time I remembered to come back and renew that line again to save it from closing in late March, the GSMT line had gone Airtime Expired for a whole month and therefore lapsed into Closed. That line offers me the renewal process and fails at the end telling me it can't be renewed because it's closed. To the best of my recollection, it all looks the same up to that point. If there are any differences that I'm not remembering, the following may be inaccurate.

I launch the app; it takes me to the last screen it was on previously and makes me watch an ad. If I'm on the screen for a line that needs renewal, there's a red RENEW button at the top. Tap that, I get another ad. After I close that ad, the bottom two thirds of the screen are a thing that tells me I qualify for the $10/mo plan and has the green button "GET STARTED" and the blue button "RENEW FREE PLAN."

Note: At least part of the time, it shows me this after the ad that plays when I open the app or switch the selector at the top of the screen to focus on a different line. However, if the line doesn't offer the RENEW button, the RENEW FREE PLAN button also won't be there.

The RENEW FREE PLAN launches a web view based on my default browser, as far as I can tell, and I believe the first time it did so I had to log in to that, separately from logging into the app. It isn't launching the browser itself, because I don't have any other tabs, but it tells me it's running in Brave. At this point I seem to be on a mobile version of their website, except it lets me manage my subscriptions, whereas the website no longer acknowledges I have any lines at all.

The fact that it pulls up a web view may mean that if either one has the permissions on their phone locked down particularly tightly, uses an unusual browser, or has a sufficiently old system webview (which might mean the app isn't fully compatible with older versions of Android), the click-through steps won't work correctly. If one is using something similar to Brave and has it configured to discard cookies after every browsing session, I would not be surprised if that also meant having to log in to the web view every time it opens.

Those are just some guesses, at this point. I could certainly understand if One is beyond the point of considering it worth any more attempts by now, though, so I don't know whether this will be of use to anyone.


I renewed my GSMA free 100/100/100 plan using BlueStacks app on Windows 10 notebook computer. It might have been easier using my phone but I just wanted to know if it could be done with BlueStacks app. It only worked after my plan expired, why it won't let you renew the day of expiration is stupid.

1 Like

Since I am not a windows user, bluestacks is not an option - funnier still, you may wonder that since Android is a Linux variant, why can't it emulate or run Android apps...a valid question...short answer=> Nuttin' doin' for that.

Once in a while I also search for 'free cellular' stuff - and there's plenty of silliness to be found.
Of course best options are for poor, old folks so as such I'm eligible for Lifeline, but most likely will not want or use it.

All this discussion has also reminded me to re-check Callcentric & Localphone vs. VOIP.MS for my VOIP needs.
CC is still overpriced (and snotty) - LP is a bit better (and polite) - but VOIP.MS is still best price, support & feature-wise.
There really isn't much left of the ITSP realm - and the ATA choices are even more desolate.

As far as fp is concerned nothing I've tried changes my view of it - a horrid company that aims to torture users 'till they either pay for it, or leave it.

So far, I just choose the leaving option.

Funny, if it came to app only renewal situation for the GSMT line I manage and in the spirit of 112059 doing a windows DP, I was thinking about trying it on my Chromebook as another DP if I had the time instead of firing up the old iPad.
I've run a few other apps from the playstore on Chromebook, many refuse to download/install so have to via Linux console. Not always a perfect user experience using an app designed for a phone/touchscreen on a large non-touch screen w/keyboard but so far I haven't run into anything that I couldn't make work.

I've been using Localphone forever for overseas calling because their rates for that are pretty hard to beat, less and less need for it but they don't expire the small balance so really easy to just continue on.


Greetings Redrotors.
A very interesting reply, thanks.

The last time I had any use for int'l calling was over 20 years ago - nowadays any calls I make are in the US only & that is what I based my thoughts here upon.

Interestingly enough - you had me remembering 2 little netbooks that I have...
An Acer Aspire that only has 1GB of RAM - and an HP Stream which does have the minimum needed 2GB of RAM for Bluestacks.

After charging that one I may give it a quick whirl to see if it'll work out


I just downloaded the FP app from Play Store onto my Chromebook and it works fine ( just a wee bit trickier to get rid of the obtrusive overlays if you don't have a touch screen)

This will make things much easier for me as I manage the renewal on four FP accounts.

1 Like

I tend to agree. At some point the frustration is not worth it. My Red Pocket (on ebay) is only 30 bucks for a whole year! That''s 2.50 bucks a month for 200 talk 1000 text and 200meg of data. Bottom line, it's worth it. (this is for T-mobile not ATT)

1 Like

Hi Frasier11.
AFAIK, the RP $30 deal is only for GSMT.

My partner's backup phone uses their $60 deal which is GSMA.

My desire for GSMA is a preference rather than any actual need, so I've been holding out for any possible success with having some for free.

1 Like

A slight update on this topic - and for once, this mostly has a POSITIVE note to it !!

After all the prior silliness trying to renew fp, I finally decided to start up w7 on my spare PC (my workbox) to install Bluestacks.

I grabbed v4 'cuz it seemed most likely to work, and it did install & open.

When trying to search in its installed G play app, it would only FC, so I used its browser instead & got the fp app installed.

It did open OK, and showed the renewal without any hassles, but demanded a CC even though it already had a CC on file.

It refused a perfectly good visa card as 'invalid', but then took an amex card OK.

It needed some few pokes to get through its checkout, and another 5 minutes or so before it reactivated - but finally updated as active.

Made a test call on that phone - it took lots of time to connect, and did work.

Finally. Phew.

1 Like