Does CellNUVO use difference Sprint network than other MVNO?

I email support to swap device.

My new phone is moto g (4th gen.) which used on RingPlus.
CellNUVO Support email me back said "We are unable to change devices as Sprint is showing that new one as invalid."

I just check with They say "Your phone wants to join Tello!"

What does the Ting device checker say?

Make sure you give them the meid rather than the IMEI. If you already did give them the other one Dec or Hex.

They use sprint just like Tello and if Tello says it is good then you should be able to use on cellnuvo as well (unless an iphone or flipphone). The ting one should say the same as the tello one.

@Bill. Try open a new CellNUVO account with that phone to see if it works. Just use your own referral code. If it does then just close the new account and explain to CellNUVO that this phone does work and you want to swap devices with your other existing account.


We check validity of phones against Sprint's database. Even though a particular phone may have worked before, it could still fail the "test" for a number of reasons. We have seen ESN's fail because the former carrier cancelled them. Some fail because they were not released from the former carrier. Some fail due to financial obligations to the former carrier. We have also seen ESN's pass, but the SIM card (ICCID) fails for similar reasons.

Our suggestion is that if you feel the ESN and ICCID are valid, confirm they have been released by the former carrier, are active and able to be moved.

Now I get NUVO email:

I receive an error message from Sprint when I try to add your SIM. Is it a typo? Or is the SIM inactive?"

This phone and SIM was used on RingPlus. How do I know if the SIM is inactive?
Need more information...

4 days without a phone here. Someone please help?

That was my real concern--might the problem have been the sim. I was pretty convinced that if Ting said the phone could be activated immediately the problem was the sim.

It does happen that sims are not properly "released" but unfortunately there is way for the user to determine that directly.

The best advice, as far as I know, is to get a new, never-activated, sim and try again.