Can lg f2 be used for text now?

I tried but Google play store said my device is not compatible with the app.

You can, if not done so already, check it on the Textnow website. Go to the page linked below and click on the "Get Started" and then click"Continue" on the next page and it'll take you to the check eligibility page.

Also, don't know what OS the f2 is running, but here is some info from the play store. Requires Android 5.0 and up now.


  • NEW FEATURE Now you can use TextNow without WiFi! Get unlimited calling and texting over the Nationwide Sprint Network -- for FREE. Check if your phone is eligible, and get phone service without the phone bill by clicking on "Free Coverage" in the app menu.
  • This is the final planned release for users on Android KitKat (4.4.0 - 4.4.4) devices.
  • Various performance improvements."

I had a Galaxy S3 (kitkat 4.4.2) that worked on both WiFi or Cellular data 12 days ago. I was going to give it to someone that could use this service but after a factory reset it will only work with WiFi. I think they changed what phones can be used after they had that outage last week.

Thank you. My phone is one from FreedomPop called LG Optimus F3. It is kitkat 4.4.4. I checked the link you provided and it said my phone is not supported. Terrible.

Could be used in tello though

Moto E2, ZTE Speed 2, anyone?

These are phones from RingPlus.

I used my old Moto E2 (that used to work great on RingPlus). TextNow's new free cellular plan gave me umpteen problems. Not sure if it was the phone's fault, or TextNow's fault.

The FreedomPop LG Optimus F3 might be problematic on a couple of fronts. Besides the older Android version, it did have something in the way of a custom FreedomPop ROM. (Source: I have one, and it came to me from FreedomPop with root access already enabled-- no reason for FreedomPop to do that if they weren't modifying the ROM in some way.) Nice little phone, but I think it also only had a single LTE band, which is another thing that makes it a poor choice for TextNow.

I think it makes sense to try the Moto E2 or Speed-- both meet minimum requirements.
peterquinn had problems with his Moto E2, but hard to tell if it's the phone itself or something in TextNow's end.

jamielih reported activating Speeds, with issues on one:

Since jamielih also reported no issues with cleanly deactivating an MEID from TextNow, I don't see any harm in trying.