Awesome Hack for ZTE Blade A7 Prime

As I have posted, previously, I've been having a terrible problem with low bandwidth since signing up with Visible Mobile.

Tonight I tried installing an app from the Google Play Store called "MTK Engineering Mode".

My phone has only used band 4, around here, with short blips over to band 13.

I opened MTK Engineering Mode, tapped "MTK Settings", then "BandMode", then "SIM1", then I unchecked bands 4 and 13, tapped "Set", and my phone switched to band 5.

Now I'm getting 10-20Mbps instead of 0.7Mbps.

I'm a happy customer!

Update: I just installed it on my LG X Charge, which is on T-Mobile, and I'm able to choose LTE bands on it, as well, even though it doesn't have a Mediatek (aka MTK) processor.

There's almost a dozen "MTK Engineering" apps in the playstore - which one are you talking about?

I didn't realize that until you said it.

It's the one by "TheMonster".

I thought band 13 was Verizon's main band. Have you tried a setup where you are only using band 13? If so, how is your speed?

I've been using band 13 all day, today, and getting about 18 Mbps.

In my area there doesn't seem to be a band 2. Band 4 is a dog. And 5 and 13 are pretty speedy.

For reasons I don't understand, though, my phone greatly prefers band 4 unless I disable it.

A neighbor of mine just signed up and was experiencing the same thing, so I showed him how to disable band 4. Now he's a happy camper, too.

I wonder if there is a similar app for the R2? In any case the "LTE Discovery" app on my R2 shows signals only on bands 2, 4, and 13 which implies I don't have band 5 here. I'm getting 5-10 Mbps here anyways - over 50 Mbps in Boston !

It's my understanding that the app I mentioned is compatible with the R2.

Different chipset it would seem - I loaded it and it complains.

You are always kind and helpful but please stay safe.

The app tells me that it was designed for an older operating system, when I start it, but it still allows me to toggle LTE bands.

It's also only supposed to work for Mediatek, but it lets me toggle LTE bands on my LG X Charge that has a Snapdragon chipset, too.

Just says "Cannot find EngineerMode app - Mediatek chipset is mandatory and stock ROM must be installed" on my R2

I just looked it up and the R2 has a Snapdragon chipset.

I know that the app is specifically created for the Mediatek processor but it's strange that it would work on my LG X Charge and not your R2.

I just tried this on a few Snapdragon phones and it got me into EngineerMode.



If it works, select BandMode, then SIM1, then deselect any LTE bands that you want to disable.

I've played around with this, some more, and I think I've learned a few things:

  1. The various "Engineer Mode" apps don't actually create an Engineer Mode. They merely provide access to the phone's Engineer Mode if one already exists.

  2. I've been experimenting with various phones in my "fleet" and go to Settings>Apps>All Apps then tap the three-dot menu and select "show system apps". I then scan down the list of running apps and look for one called EngineerMode. If EngineerMode is present I have been able to access it with an MTK app, even when it wasn't a Mediatek processor. And if I can access it, then I can deselect unwanted LTE bands.

I don't have a ZTE R2 but, from what I've read, it does not have an Engineer Mode.

I also found that my Verizon Prepaid Moto E4 phones don't have Engineer Mode.

Obviously, the ZTE Blade A7 Prime does. So does the LG X Charge.

I'd be interested to see what other people find with their phones.

  1. Check to see if you have a system app called EngineerMode.

  2. Try to access it with an app from the Play Store or by dialing ##3646633##

  3. See of you can access the LTE bands by tapping BandMode>SIM1

  4. Post your results, with phone model, here.

I grabbed the phones nearest me to see if EngineeringMode existed, & here's what I found:

  1. Moto E6 from Visible - NO
  2. Moto G6 from GoogleFi - NO
  3. BLU R1HD Amazon model - YES
  4. Boost ZTE Speed (running KitKat still) - has a system app called Emode (don't know if that's EngineeringMode)

I'll report back with the other devices later.

Moto X4=NO
Moto G5s+=NO
Umidigi A3-Pro=YES

So it's looking like Moto doesn't include Engineer Mode.

When y'all dial the Engineer Mode access code into the phones that have it, do you get access?

If not, you'll need an app.

For moto phones ##3282##

Yes, access on Umidigi A3-Pro, where all sorts of options are listed, including switching to CDMA networks, which I had no idea.

Moto G4 Play-- mmfacemm's suggestion gives me access.. Path Data Settings/ LTE/Bands gives access to disable particular bands, and a menu to set priority among enabled bands. (I like this better than entirely disabling bands, since they might be needed somewhere else....)

There is no system app named something like Engineering Mode, though.