TextNow Free Service

As long as mobile data is enabled.

It won't work on just a cellular voice connection.

Not an app - It is baked into my sprint phone as a setting. I thought it was VoLTE but they say it is voip over lte. Probably why it works.


Not long ago there were discussions about whether the new Ooma Genie device was cellular or VOIP, particularly since home internet wasn't required to use the device. It seems the distinction between cellular and VOIP is no longer what it used to be since cellular data is being used for voice over internet protocol calls via cellular networks, if that makes sense. Whatever it is called, it's apparently free on TextNow.

I just tried using Tunnelbear VPN and it wouldn't connect.

It's been over two years ago, but I did port my number in to TN then after a couple months ported out due to the voip or volte delay. Back then there was another number you could use to get true cellular in and out, they told me what mine was when we were diagnosing the delays.

Edited to add info: According to TN virtual assistant you can port numbers in.

I can confirm working on iPhone 5c. As others have stated, VoIP over cellular data. Seems similar to Freedompop zero-rating cellular data used for voice calls.

Textnow has free calls to several foreign countries which is nice. The latency was pretty severe though when I tried it out over textnow sprint.

It was fun to try out for an hour but I don't really see the appeal in this personally. Voip is never as good as cellular and unless you talk a lot something like the $3 redpocket plan will be so much better and free of ads. You'd get some data too. Many of us have freeup plans too. I guess though to the nth crowd free is free so sign me up :stuck_out_tongue:

So this is 3G/LTE connection running at '2g speed', not actual 2g, right?

Yes it is LTE. The app said it was an excellent connection when I made a call with 2 bars. So I guess it good enough for this purpose.

I'm not entirely sure what speed it is running at since I cannot run a speed test but the speed it loads google.com it is probably 2g speeds

We would need to order the Sim card? If so on text now website?

No cost for Sim?

The SIMs from your old R+ phones will work fine.

One plus for the TN plan is that no personally identifiable or billing information is required in order to sign up.

An email address is all you need.

So possible trade-off versus FreedomPop's free VoIP.

TextNow has no reports of odd billing practices, random charges, and changes to TOS. (And as Chelle points out, the free plan doesn't require any billing information.)
The reports I've seen of TextNow's VoIP quality are pretty good.
Despite theoretically being zero-rated, in practice VoIP via FreedomPop typically does count against data-- no such worry with TextNow.
More minutes/texts with TextNow offer.

FreedomPop AT&T probably has better nationwide coverage.
FreedomPop data can be used for anything you want, not just VoIP.
FreedomPop's served ads are minimal, and non-existant if you don't use install the app, while TextNow's ads are obtrusive.

Perhaps I'll start seeing something different but I haven't found the TN ads to be obtrusive, yet.

My definition of an obtrusive ad is one that I have to close or otherwise interact with in order to proceed.

The TN app merely displays banner ads at the bottom of the app. You can look at them or ignore them.

Like I said-- that could change but, so far, they're pretty reasonable.

Got service on iphone 5c. The same one I used with same sim on ringplus and fpop

So I did the profile update and PRL update (3 or 4 times, for good measure!) and also rebooted 3 or 4 times. Same mysterious things keep happening as before --

  1. Chameleon tells me to sign in and I have to tell it to "use network as is" before I am allowed to make a phone call. (Otherwise it says "poor mobile data connection" and boots me out of the dialer)

  2. The native texting app doesn't let me send texts -- I get "you are not allowed to send text messages. Msg 2120". (For me, TextNow's texting interface is very cluttered with ads that fill half the screen, so I don't want to use it for texting. I could use GV to text, but GV uses my GV number to text, not my new TextNow number)

  3. I downloaded a texting app that doesn't have ads. That one too doesn't let me text. I get that same "you are not allowed to send text messages. Msg 2120" from the number 9230. I'm thinking it's TextNow's way of ensuring that ads can be fed through their texting app.

Any light you can throw on these much appreciated.

From SD wiki -
Phone number Recycles if no use after 1 week. You can sign back up through the app to get another number.

peterquinn, I would not expect the native texting app to work-- it requires a cellular voice connection, which this plan does not have.

Nearly any alternative texting app requires data-- and general data usage is blocked by the profile.

It's been pointed out above that hangouts texting is for some reason not blocked. You might try Hangouts, or continue to look for another texting app that is not blocked. (I don't want to discourage that search, but expect that failure will be the norm.)

Yes no native anything should work. It is supposed to be routed through the app. If you can use the native dialer with the textnow number then count yourself lucky. The whole point is you get it free because of the ads.

You'll see full page ads too soon that you have to X out. At least I get them. Sorry.