Surveys That Won't Open

From time to time, KentE mentions that he has surveys that unsuccessfully and repeatedly try to open in his CellNUVO app. He hates to miss out on them because they pay lots of silver (100 to 225 per survey).

My LG X Charge, on T-Mobile, with Android 7.1.1 never experienced that, however. Every survey opens and every survey pays. In fact-- that's how I get most of my gold. I've discovered that if do 5 swipes, at different times of the day, I can almost always get one or two surveys in those few swipes. I accumulated 1 gold, just yesterday, as we drove from Nebraska to Tennessee, simply by swiping a few times every few hours.

I also recently started swiping on a Moto G4 Play, on Sprint's free year, with Android 7.1.1. I didn't expect to see much difference but, instead, I find myself stuck in "KentE hell".

Those lucrative surveys keep trying to open up-- in fact, they always look like they're just about to finish loading-- then I suddenly find myself back at the CellNUVO home screen.

I don't know if it has to do with the phone or the cellular carrier, but it's a pretty big deal.

I'm of the opinion that, without those surveys, it's not worth the time to use the CellNUVO app. If your phone won't load the surveys-- you need to start using a different phone.

  1. Are any of you with Moto G4 Play phones able to complete the surveys? If so, are you still on Android 6.1 or have you upgraded to 7.1.1?

  2. Are any of you on the Sprint free year able to complete the surveys? If so, what phone and Android version are you using?


Don't think it Sprint issue. I do 100 silver surveys that never credit.

The non crediting has got to stop. Wether it is ads or surveys

We all deserve 5 gold for all the non credit s

That's what's strange. I've never had a survey not credit when using my LG X Charge. I can't even get one to load, however, when I try to use my Moto G4 Play.

Ads are another thing, all together. I would say that, fully, one third of the ads either don't have a point value associated with them or do have a point value but don't credit. If it weren't for the surveys I would have thrown in the towel, weeks ago.

The 100 silver never credit but the larger surveys do credit

If you had Tesla Auto Pilot, you could have swiped the whole trip. ;p

Or broadsided a commercial truck crossing the road...

re: "KentE hell": I suspect that successfully loading a survey, and correctly crediting a completed survey, are 2 different issues.
I'm intrigued by Chelle's experience-- I'd chalked up my difficulty with surveys loading to my woefully underpowered phones. (running Android 6, but with only 512mb of RAM and only about 600mb of free available memory if I keep it cleaned up.)
Chelle's Moto G4 Play is far from underpowered, though.

I swipe exclusively on my home WiFi, which is healthy, no VPN, no intentional blocks, etc. My 2 phones are similar BLU models, but not identical. One used to load surveys reliably, while the other never did. Lately (3 weeks?), neither will reliably load surveys, although the 'good' one will occasionally. .

Chelle, I'd be interested to see if you get the same results when both phones are on the same WiFi network. That might tell whether it's the network used, or the phone itself.

In the last few months, I've relied more on match games than surveys. The survey loading problem is a double-whammy: no points from surveys, and no chance at winning a match game since the non-functional survey keeps being served up & making a bingo win very unlikely.

That's a good idea, Kent. I'll try that, today.

Confirming Moto G4 Play (non Amazon Prime version) works with Sprint free for a year using Android 7.1.1.


I, too, have the non-Amazon Prime version, so we're using virtually the same setup.

My LG X Charge is an Amazon Prime version, however-- and surveys work fine on it.

Very strange!

E4 no go. Used to work

@PEW, Thanks for "steering" us all in the right direction! :slight_smile: Come to think of it, maybe Tesla can add an auto-swipe option, which of course would automatically disengage if the car is about to (side)swipe anything.

Looks like you guys got a jump on Happy Hour, today.


Which app version are you using?

With all other possibilities being eliminated, it comes down to the particular phone itself. Maybe the phone has some apps that preventing the surveys from loading or the OS itself is corrupted. I'd factory reset the phone (of course, back-up anything important as factory reset will erase everything on phone) and have on Cellnuvo app on there and see if surveys would load. Then only then I'd gradually install one app at a time testing if it's conflicting with the surveys.

Not worth it for me

Maybe wait for new cellnuvo app update Tom and support says is coming real soon

I think this is very good advice. There is 'something' that makes some phones not play nice with the app, and other than early Android version (4.x), we haven't had much luck in pinning it down. I wonder if an ad-blocker might matter?

In my instance with my BLU phones, it's not likely to be a competing app-- I don't think I have anything other than Chrome and Puffin browsers loaded, since there is no space for apps. (I had to delete a couple of apps, including FreedomPop Messaging, to get enough free space to be comfortable with space for CellNuvo.) Still, I should carefully check for setting discrepancies between the two.

I have the same apps loaded on both phones.

I took Kent's suggestion and tried it using WiFi and the surveys opened fine-- so it might have something to do with the routing through Sprint.

I'll try more experiments.

@Kent. Another idea is to uninstall and reinstall Cellnuvo app. Sometimes app gets corrupted. If that doesn’t work, then I’d factory reset.

I've tried the uninstall/reinstall on my phone that never opens the surveys. I have not tried the factory reset suggestion, and it seems worth a try-- it's possible the problem is a left-over artifact of some app I used to have loaded. Since I only use the phone for swiping and a little internet browsing, a factory reset should be painless.