iPhone 5 Data Not Working

I just activated an iPhone 5 on Nuvo a day ago, and everything works except data connection. Whether I'm on LTE, 3G, or 1x; the phone either says I'm not subscribed to cellular data or could not activate cellular data network.

Are you sure you have the right sim?
The 5 has a less common model.

If you are confident about that, try toggling Data off/on and then ##CLEAR#. and ##UPDATE#.

ETA: Check ICCID on account matches phone.

I know I have the right SIM b/c I've used it on R+ before. I have also clear subscriber settings and updated profile to no avail. (To clarify, voice and text work fine.)

Iphones are not officially supported yet. How did you get it onto your account? Did you activate an android phone first and then contact support to swap in an iphone? Or were you able to sign up with an iphone from www.cellnuvo.com (that it usually blocked) ?

The way the system works is that you need to install the cellnuvo app and input an activation code to activate the device first before you can use it fully. The iphone app is currently in development and is overdue. So there is no way to directly complete activation until that is launched.

I did contact support to swap it in, but I don't see why it wouldn't have worked if I had just activated it normally. I get that iPhones aren't fully compatible with Nuvo due to lack of an app, but using the network shouldn't be a problem. I use another Android phone to earn credits.

I tested my iphone that used to work and data is not working. So maybe it is happening to all iphone users? I'll reach out to cellnuvo to see if they know anything. I'm getting service update fail errors now too.

The other person I know who was trying to get an iphone set up couldn't get it to work at all so gave up. They had service update failed errors. Same as what I am getting now :frowning:

@mmfacemm I'm not getting any service update errors. Are your voice and text working fine too?

What happens when you do ##873283# That is where the service update failure comes from.

Yes voice and text work fine.

My data used to work so this is odd. I have a feeling it has to do with their iphone app testing or something. Maybe the app is coming.

I sure hope the app comes soon. Anyway, here is a successful service update just now https://ibb.co/jEUtdQ.

Okay I managed to get a service update completed and my data works now.

I have no idea what to suggest to get yours to work. Perhaps ask customer service to swap back in your android phone, update the activation code in the app with a new one. Then swap in the iphone again. Maybe the refresh might help. The old swap in and out trick.

Were you saying that data worked for you on Nuvo in the past or only on another MVNO?

It worked on cellnuvo with my iphone in the past. It is now working again after I got the service update to complete.

It might be worth the sim removal trick and if that does not fix it to attempt a restore . The other thing that can be done is check apn settings. These can all be done by a user.

Of course if Data has never worked location has not been excluded yet.

An account refresh would be safer that 2 swaps and might be worth trying first.
Ideally CellNUVO should confirm LTE is working at the account level.

Unfortunately sim removal didn't work, and iPhone doesn't have APN settings (at least not on Sprint). Also, I have perfectly good Sprint signal, and have used both R+ and FP in the past. What were you saying about acct refresh or Nuvo support confirming LTE (w/o typos and w/ more clarity please)?

Perhaps it was just a temporary server issue on Nuvo's part based on what @mmfacemm said about data working in the past, but my data still isn't working.

Could have been a sprint server issue. The tello meid checker is throwing out odd results today too. Doesn't explain your particular data issue though.

Sometimes when you swap in a new phone it just doesn't work properly. In the R+ days the quick fix was to swap a new phone in and then swap the phone you want back in. That seemed to fix many problems. That is all I can suggest right now.

Well darn, it looks like it'll take at least another day or two for me to get up and running considering how slow CS is.

CS seems to insist that swapping devices doesn't help, so they have done a couple of network resets for my device to no avail. They will contact Sprint to sort out my device's "handshake" with the network.

Update 2

I'm no longer having issues with my data connection. Nuvo said in an email that they would submit a ticket to Sprint to reset the device's "handshake" with the network. Whether they did that, a device swap, or nothing, I don't know. Anyway, it worked after an iTunes restore and ##update# over wifi.

Great stuff! Good job cellnuvo