Having problems enabling LTE on a Sprint MVNO?

Try downloading the "Change APN" app, and choose "Reset to default" from the menu.

Worked for me when everything except a factory reset would not.

I just ran into this with two phones moved to Tello. Update PRL and profile didn't fix it-- still only got 3g. I did the ##72786# thing and it fixed it.

The APN thing cropped up a few times this week over on the Twigby forum. Sometimes the ##72786# doesn't help and it needs the APNs fixing.

Where is the Twigby forum?

thread / forum whatever

The APN fix is usually only required for Unlocked phones like the Nexus and Motorola devices.

The Nexus 5X all you have to do is dial ##data## > then tap APN in the menu > tap the 3 dots at the top right > tap reset to default> back out and carrier reset ##72786##
You really should be able to find a similar path on the Motos as well, but change APN does work as well.

It is always wise to perform a carrier reset ##72786# (##72786## most carrier agnostic Sprint compatible devices) whenever moving a device over to a new Sprint MVNO.
If you are activating a place holder and then swapping in a device to replace that place holder, I always run a carrier reset before and after the swap.