Hangouts problem

Anyone else getting this problem?!topic/hangouts/5isoXIgcj2M

I keep getting "The following phone number is too long:..." "maximum SMS recipient is 11 digits,..."

*** Error on new SMS only, reply on existing threads work fine. ***

I understand this but I am trying 10 digit number. First I thought it was because I had () around area code but after deleting them it still gives same error. Uses of (xxx)xxx-xxxx; xxx-xxx-xxxx; xxxxxxxxxx All give same error. (Samsung Note 4 Android Lollipop, browser plugin in Chrome doesnt give me option to SMS just states they are not a Hangouts user when I try to message.)

Hangouts is my default messaging app. Google Voice account and Gmail same user name/account. I am still able to SMS my old contacts.

You could try un/re installing Hangouts app. Testing, as suggested, with another number when feasible sounds like a good idea.

Not an exact problem as you have noticed, but may be related: the web hangouts version cannot send sms on a wifi only device. I tested this using my cell phone (works), LTE tablet (works), and laptop/tablet combo (does not work). I'm going out on a limb guessing that Google is cutting back on the capabilities of Hangouts going forward unless you opt for the paid version (businesses).

I have only skimmed some info about the re-purposing of Hangouts-- but it occurred to me that the juxtaposition of "hangouts" and "business" is jarring.

I just tested web version on Win 10 using Chrome browser, & I was able to send SMS to my CellNuvo's temporary phone number.

On Chromebook Hangouts app, it works when you input the #... but not by selecting contacts.

On the phone, I am getting the same error on both phone with cell svc and another with just FP app (cell data). Same error.

Going back to Google Voice on the phones for the interim. GV works fine for SMS.

Also loaded Google Voice app from Chrome Store for Chromebook.

... but I lose the ability to group text. Messages are split to each recipient as individual messages.

Glitch... switched to Legacy Google Voice, now switched back to Hangouts - works fine.