CN app not working with Android 4.1.2?

I've been using an old phone running Android 4.1.2 for swiping

During the last week or so, the app has failed to start any video add-- just goes to a black screen I can't exit from. I have to force stop the app to get out of it.

I've tried updating the app: it didn't help. The last update actually made the problem even worse-- now the keyboard won't come up to enter an email address on static ads requiring that, either. (It flashes open, then disappears again.)

So tonight I deleted and reinstalled the app from the Play Store.
No help, same symptoms.

Has anyone else seen this issue, or have any suggestions I could try?

My other CN line runs on an Android 4.4.2, and it's working fine.

I would try the following. Probably won't help worth a try

1). Delete the cashe for all phone or at least cellnuvo app

  1. uninstall app
  2. reset Google I'd
  3. reistall app. ( Have you tried different versions?

Great list! I think I tried all of those suggestions, except 4b (trying a different version).

In order, with each step followed by testing, and a phone restart after initial repeat of the symptoms:
Force stopped app, and cleared cache in CN app.
Updated app.
Uninstalled app and re-installed.
Cleared cache in browser.
Reset Google ID
Maybe tomorrow I"ll try installing an old version.

For what it's worth, no significant changes in the device, no other new apps, etc. The keyboard does still come up on other apps. I'm usually pokey about updating the app, and I think the initial appearance of the symptoms wasn't preceded by an app update.

Tonight, I sat down to revert back to an older version of the CN app, kindly provided to me by a forum member. In the interest of being thorough, I tried my current version one last time before uninstalling it.
But.... it works almost fine now. Videos load, play, and credit. The keyboard still won't come up to enter my email address on the one ad that requires it, but it's only a 2-silver ad anyway: and it seems to usually credit anyway if I just click on the entry field a couple of times & then close the ad.

I didn't change anything else after uninstalling/reinstalling yesterday, so I'm not sure why it's working now. I think I'll leave well enough alone for now, and keep the old version handy in case the issue returns.

I'm having the same issues on my older phone as well. Perhaps another example of planned obsolescence?

I'm just leaving it alone and swiping along, getting whatever silvers will credit.