T-Mobile Test Drive question

More
2 months 3 weeks ago #1 by peterquinn
I ordered a Test Drive device more than a month ago. Got the confirmation e-mail, and then heard nothing from them. I thought I was out of luck, but I got another e-mail and have received the device.

How long before I need to activate it? I don't need 30 GB right away but I don't want to waste the data either. So I'll hold on to it until an emergency need arises and then activate it. Does T-Mobile remind you that it needs to be activated?

Thanks in advance for your answers! 

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #2 by KentE
Replied by KentE on topic T-Mobile Test Drive question
I did this in an earlier offer: the device needed to be activated within 90 days.

As for a reminder: yes, kind of: and not exactly: in my case.

I didn't receive any reminders. But somewhere just short of 90 days, I got an email from T-Mobile welcoming me to my new line. Took me a while to figure out (with the help of a customer service agent) that T-Mobile had activated the Test Drive without any direct request from me. I was fine with that, since pandemic realities meant I'd had no need of 'mobile' data. I didn't get much use out of the data, and didn't even get to put it through it's paces in various locations: just a few spots in town, and briefly in one remote location. But I definitely got more use out of it than if T-Mobile had just quietly expired the plan. I have no idea if this is standard operating procedure for Text Drive units or not.

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #3 by peterquinn
Here's something strange:
"100 GB per year" -- that's what is listed under 'Plan' in the Admin settings for my test-drive.

Is that just a "typo"? I tried googling it to find out, but no luck.

Thanks for any light anyone can shed on this!

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #4 by bingyee

Here's something strange:
"100 GB per year" -- that's what is listed under 'Plan' in the Admin settings for my test-drive.

Is that just a "typo"? I tried googling it to find out, but no luck.

Thanks for any light anyone can shed on this!

Do you have the TMOHS1 ?  I think the 100gb indicator is the default of the device itself.  I only got 30gb when I did my test drive in the spring. 
 

Please Log in or Create an account to join the conversation.

More
1 month 18 hours ago #5 by peterquinn

Do you have the TMOHS1 ?  I think the 100gb indicator is the default of the device itself.  I only got 30gb when I did my test drive in the spring. 

 
Yes, that's the model number on mine.
The defaults on that device are puzzling - for example, the inactivity period default is 10 minutes. So if there's no hotspot activity for 10 minutes, the unit shuts itself down, and the user is supposed to go and turn it back on. That's such an inconvenient default value for a hotspot device, IMO.

@bingyee, Did yours show 100 GB/year as the default plan too?

Please Log in or Create an account to join the conversation.

More
1 month 5 hours ago #6 by bingyee

Do you have the TMOHS1 ?  I think the 100gb indicator is the default of the device itself.  I only got 30gb when I did my test drive in the spring. 

 
Yes, that's the model number on mine.
The defaults on that device are puzzling - for example, the inactivity period default is 10 minutes. So if there's no hotspot activity for 10 minutes, the unit shuts itself down, and the user is supposed to go and turn it back on. That's such an inconvenient default value for a hotspot device, IMO.

@bingyee, Did yours show 100 GB/year as the default plan too?

Yes.  I recall seeing 100gb initially.  I haven't checked recently, definitely not since my test drive ended.

The hotspot shuts off when there's no activity, unless the unit is plugged in to power.  Obviously, you don't want to do that continuously with your battery in place. However, the TMOHS can maintain power when plugged in without the battery.  What you need to do is plug the unit up to power when the unit is fully off, wait about 5 seconds, and pull the battery out as the unit is beginning its start-up routine.  If you pull the battery out too early or too late, it will shut off again...just try again.  Just the right time and the unit will stay on until you pull the plug out again (or there's a blackout).

Please Log in or Create an account to join the conversation.