Unable to access unlock app on Tmobile moto e6 phone

More
1 week 11 hours ago - 1 week 5 hours ago #44161 by michellesmith89898
I am hoping that someone here can help me. I purchased a $100 Tmobile epin to obtain a free moto e6 phone. I did this twice (once on two different days at different stores) in order to obtain two free phones for older parents who are currently using flip phones that will no longer work once the 2g/3g shutdown is complete. Both parents are on grandfathered tmobile plans (one is on the gold rewards plan and the other is on the $3/month plan).

To comply with the terms of prepaid unlocking, I made a few calls on the day that each phone was purchased. The next day, I added the $100 epin to the account so that I could unlock the phone.

Unfortunately, I am unable to access the Tmobile unlock app. Support keeps telling me that the only way to unlock the phone is by using the app, but I cannot access the app. Although they keep telling me that it should be in the Tmobile folder, the only items there are a T-Mobile app, a Name ID app, and a Visual Voicemail app.

This is happening on both of the new phones, so I doubt that I have two defective phones.

When I go into the phone's settings app and look at the installed apps, I do see an Unlock app. It says it is installed. "Disable" is grayed out. I can "force stop" the app. I do not know any way to run this app.

I already performed a factory reset with the same result.

I also tried a non-T-mobile SIM in the phone just in case the phone was already unlocked. It is not. When I turn on the phone I receive a message stating that the phone is carrier locked.

Can anyone here help me? Tmobile keeps telling me that I have to use the app that I cannot access.

Edited to fix a typo.: The message after inserting a non-T-Mobile SIM stated that the phone was carrier LOCKED.

Please Log in or Create an account to join the conversation.

More
1 week 9 hours ago #44163 by Isamorph
"I also tried a non-T-mobile SIM in the phone just in case the phone was already unlocked. It is not. When I turn on the phone I receive a message stating that the phone is carrier unlocked."
Wondering what non-T Mobile sim you tried with the phone? Maybe the phone is carrier unlocked after all since you do receive that message. You can run your phone's IMEI # through the eligibility checkers at MVNOs such as Tello(Sprint) to see if your phone is ready to be used on their networks and is thus unlocked.
You can also file a complaint with the FCC which can result in corrective action by the phone carriers.

Please Log in or Create an account to join the conversation.

More
1 week 9 hours ago #44165 by KentE
I sympathize with your frustration! I tried following T-Mobile's own directions for locating a 'how-to' for this for your phone, and the directions for the path does not match the actual help section. (It seems they've reorganized the help section, without doing a matching update on how-to use the how-to section to find this info......)

From reading a little elsewhere, it does appear the app is supposed to be triggered by inserting a non-T-mobile SIM. What provider is your SIM from?

You wrote: "When I turn on the phone I receive a message stating that the phone is carrier unlocked." Did you mean to see "carrier locked"?

Please Log in or Create an account to join the conversation.

More
1 week 9 hours ago - 1 week 8 hours ago #44167 by Isamorph
"If the app is not listed, make sure it is not disabled or hidden on the device. The app will uninstall itself after a permanent unlock."

www.t-mobile.com/support/plans-features/t-mobile-device-unlock-app

www.t-mobile.com/support/devices/android/motorola-moto-e6/hide-or-show-apps-moto-e6
The following user(s) said Thank You: KentE

Please Log in or Create an account to join the conversation.

More
1 week 5 hours ago - 1 week 5 hours ago #44174 by michellesmith89898
I made a typo in my original post. When I inserted an AT&T prepaid SIM in the Moto e6, it said that it was carrier LOCKED, not carrier unlocked as I previously posted.

Inserting the AT&T SIM did not change the results. I still cannot access the unlock app.

I have no idea how to unhide an app. As previously stated, the unlock app is on the phone. I just can't open it and use it. I can see it in the list of phone apps in the phone's settings.

Please Log in or Create an account to join the conversation.

More
1 week 5 hours ago - 1 week 5 hours ago #44175 by Isamorph

michellesmith89898 wrote: I made a typo in my original post. When I inserted an AT&T prepaid SIM in the Moto e6, it said that it was carrier LOCKED, not carrier unlocked as I previously posted.

Inserting the AT&T SIM did not change the results. I still cannot access the unlock app.

I have no idea how to unhide an app. As previously stated, the unlock app is on the phone. I just can't open it and use it. I can see it in the list of phone apps in the phone's settings.


The link below shows how to hide and unhide an app.

www.t-mobile.com/support/devices/android/motorola-moto-e6/hide-or-show-apps-moto-e6

"If the app is not listed, make sure it is not disabled or hidden on the device. The app will uninstall itself after a permanent unlock." Which is from the below link.

www.t-mobile.com/support/plans-features/t-mobile-device-unlock-app

Please Log in or Create an account to join the conversation.

More
1 week 5 hours ago #44176 by michellesmith89898
Since "Disable" is grayed out for the unlock app, I would assume that the app is enabled.

I also assume that it is enabled, since I can "force stop" the app.

I just don't understand why I cannot open the app.

This may or may not be important: When I called T-Mobile, they said that their records show that the device has never been used on their network. However, I made 2 calls and one text using the phone yesterday. I did not add the $100 refill until early this morning.

Please Log in or Create an account to join the conversation.

More
1 week 4 hours ago - 1 week 4 hours ago #44177 by Isamorph

michellesmith89898 wrote: Since "Disable" is grayed out for the unlock app, I would assume that the app is enabled.

I also assume that it is enabled, since I can "force stop" the app.

I just don't understand why I cannot open the app.

This may or may not be important: When I called T-Mobile, they said that their records show that the device has never been used on their network. However, I made 2 calls and one text using the phone yesterday. I did not add the $100 refill until early this morning.


If you just added the $100 today, which is necessary to qualify for unlocking, then it could be it will take a while for the Tmobile system to update the account at which time you may be able to unlock the device. We're you trying to unlock the e6 before adding the $100 to the account?

"Prepaid accounts

The device must have been active on the account for at least one year;
OR
The Prepaid account using the device must have more than $100 in refills since device first use date."

www.t-mobile.com/support/devices/unlock-your-mobile-wireless-device#secondheading

Please Log in or Create an account to join the conversation.

More
1 week 4 hours ago #44178 by michellesmith89898
I did not try to unlock the phone before adding the $100 epin to the account.

Perhaps the system has not updated yet, since I added the $100 to the account earlier today. I will wait until next week before trying to find the unlock app again.

Thanks, everyone, for the suggestions. I will post an update after T-Mobile has had ample time to update their system.

Please Log in or Create an account to join the conversation.

More
1 week 1 hour ago #44184 by mmfacemm
just contact them via twitter they usually help people out there vs standard channels.

Please Log in or Create an account to join the conversation.